顶部左侧

黄金狙击(通达信公式 主图 源码 测试图)可用于手机公式源码(图文)行情软件

2020-01-20 16:57:22 阅读()
导读: 黄金分割使用方法:总纲:买在压力,卖在支撑 买点,截取胜率89%的指标 低吸,截取实用的低点指标,低位必须出现底部才能进,对付连连板大妖,跌的不能再跌的最好 本公式黄金狙击 的

 黄金分割使用方法:

总纲:买在压力,卖在支撑    

买点,截取胜率89%的指标    

低吸,截取实用的低点指标,低位必须出现底部才能进,对付连连板大妖,跌的不能再跌的最好

 

本公式黄金狙击 的源码,可以用在通达信手机公式

 


MAA5:MA(C,5),COLORFF00FF,LINETHICK2;

MAA10:=MA(C,10);

MAA30:MA(C,30),COLORRED;

KS:IF(MAA10>MAA30,MAA10,MAA30),COLORBLUE;

A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

A4:=SMA(A3,3,1);

A5:=SMA(A4,3,1);

A6:=3*A4-2*A5;

A7:=C-REF(C,1);

A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);

买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;{红1}

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);{分析家公式网}

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,1),COLORYELLOW;

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR 

VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),5,2),COLOR00FF00;

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00C8FF;

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10FFFF;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;

PMA:MA(C,5),COLORWHITE,LINETHICK2;{分析家公式网}

IF(PMA>REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2;

T:=150;

TT:=3;

N1:=0;

高1:=REF(HHV(H,T),TT); 

低1:=REF(LLV(L,T),TT);

H1:=高1-(高1-低1)*0.191; 

H2:=高1-(高1-低1)*0.382; 

H3:=高1-(高1-低1)*0.5; 

H4:=高1-(高1-低1)*0.618; 

H5:=高1-(高1-低1)*0.809;

顶:REFDATE(高1,DATE),COLORFFFF00;

一:REFDATE(H1,DATE),DOTLINE,COLORYELLOW;

二:REFDATE(H2,DATE),DOTLINE,COLORMAGENTA;

三:REFDATE(H3,DATE),DOTLINE,COLOR00FFFF;

四:REFDATE(H4,DATE),DOTLINE,COLORMAGENTA;

五:REFDATE(H5,DATE),DOTLINE,COLORYELLOW;

低:REFDATE(低1,DATE),COLOR00FF00;

TT4:=(CURRBARSCOUNT=1);

DRAWTEXT(TT4 AND 顶,顶,'顶'),COLOR208FFF;

DRAWTEXT(TT4 AND 一,一,'0.809'),COLOR208FFF;

DRAWTEXT(TT4 AND 二,二,'0.618'),COLOR208FFF;

DRAWTEXT(TT4 AND 三,三,'0.5'),COLOR208FFF;

DRAWTEXT(TT4 AND 四,四,'0.382'),COLOR208FFF;

DRAWTEXT(TT4 AND 五,五,'0.191'),COLOR208FFF;

DRAWTEXT(TT4 AND 低,低*1.009,'底'),COLOR208FFF;

涨停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0984,1.110) AND C=H AND C>O; {蓝心板} R1:=(C>REF(C,1) AND C>REF(C,2));R2:=(REF(R1,1) AND C<=REF(C,1) AND C>=REF(C,2));R3:=(REF(R2,1) AND C>=REF(C,1) AND C<=REF(C,2)); R4:=(REF(R3,1) AND C<=REF(C,1) AND C>=REF(C,2));R5:=(REF(R4,1) AND C>=REF(C,1) AND C<=REF(C,2));R6:=(REF(R5,1) AND C<=REF(C,1) AND C>=REF(C,2)); R7:=(REF(R6,1) AND C>=REF(C,1) AND C<=REF(C,2));R8:=(REF(R7,1) AND C<=REF(C,1) AND C>=REF(C,2));R9:=(REF(R8,1) AND C>=REF(C,1) AND C<=REF(C,2)); RA:=(REF(R9,1) AND C<=REF(C,1) AND C>=REF(C,2));RB:=(REF(RA,1) AND C>=REF(C,1) AND C<=REF(C,2));RC:=(REF(RB,1) AND C<=REF(C,1) AND C>=REF(C,2)); RD:=(C<REF(C,1) AND C<REF(C,2));RE:=(REF(RD,1) AND C>=REF(C,1) AND C<=REF(C,2));RF:=(REF(RE,1) AND C<=REF(C,1) AND C>=REF(C,2)); R10:=(REF(RF,1) AND C>=REF(C,1) AND C<=REF(C,2));R11:=(REF(R10,1) AND C<=REF(C,1) AND C>=REF(C,2));R12:=(REF(R11,1) AND C>=REF(C,1) AND C<=REF(C,2)); R13:=(REF(R12,1) AND C<=REF(C,1) AND C>=REF(C,2));R14:=(REF(R13,1) AND C>=REF(C,1) AND C<=REF(C,2));R15:=(REF(R14,1) AND C<=REF(C,1) AND C>=REF(C,2)); R16:=(REF(R15,1) AND C>=REF(C,1) AND C<=REF(C,2));R17:=(REF(R16,1) AND C<=REF(C,1) AND C>=REF(C,2)); R18:=(REF(R17,1) AND C>=REF(C,1) AND C<=REF(C,2));R19:=((REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13  OR R14 OR R15 OR R16 OR R17 OR R18,1)) AND R1); R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD); 蓝心板:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1); {绿心板} RSV9:=(C-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K1:=SMA(RSV9,3,1); DK1:=K1-REF(K1,1);出手就赢:=IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0); 绿心板:=(出手就赢=50 OR REF("KDJ.J",1)<0) AND "KDJ.J">0; 红心板:=蓝心板 AND 绿心板; 红色持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC; 短进:=R19; 青色观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18; 急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14;品红离场:=R1A; STICKLINE(C>=O,L,H,0,0),COLOR0000CC;STICKLINE(C<O,L,H,0,0),COLOR999900;STICKLINE(1,C,O,3.5,0),COLOR858500; STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;STICKLINE(红色持股,C,O,2.8,0),COLOR000055;STICKLINE(红色持股,C,O,2,0),COLOR000088; STICKLINE(红色持股,C,O,1.5,0),COLOR0000AA;STICKLINE(红色持股,C,O,1,0),COLOR0000CC;STICKLINE(红色持股,C,O,0.5,0),COLOR0000EE; STICKLINE(青色观望,C,O,2.8,0),COLOR555500;STICKLINE(青色观望,C,O,2,0),COLOR888800;STICKLINE(青色观望,C,O,1.5,0),COLORAAAA00; STICKLINE(青色观望,C,O,1,0),COLORCCCC00;STICKLINE(青色观望,C,O,0.5,0),COLOREEEE00;CO:=(C-O); 绿心过滤:=IF((蓝心板),DRAWNULL,绿心板);蓝心过滤:=IF((绿心板),DRAWNULL,蓝心板); STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA; STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;STICKLINE(短进,O,O+CO/3,2.8,0),COLOR335555; STICKLINE(短进,O,O+CO/3,2,0),COLOR338888;STICKLINE(短进,O,O+CO/3,1.5,0),COLOR33AAAA;STICKLINE(短进,O,O+CO/3,1,0),COLOR33CCCC; STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA; STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE; STICKLINE(涨停 AND 蓝心过滤,O,C,0.4,0),COLORBLUE;STICKLINE(涨停 AND 绿心过滤,O,C,0.4,0),COLORGREEN;STICKLINE(涨停 AND 红心板,O,C,0.4,0),COLORRED; {均线} EXPMA5:EXPMA(C,5),COLORWHITE;

VAR82:=(2*CLOSE+HIGH+LOW)/4;

VAR83:=IF(YEAR>=2099 AND MONTH>2,0,1);

VAR84:=LLV(LOW,5);

VAR85:=HHV(HIGH,4);

散户:=EMA((VAR82-VAR84)/(VAR85-VAR84)*100,4)*VAR83;

庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR83;

DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'低吸'),COLORWHITE;

DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,'2'),COLORWHITE;

VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;

VVAR2:=REF(VVAR1,1);

VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;

VARZZ1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-

3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);

VARZZ2:=8;

CC:=CROSS(VARZZ1,VARZZ2);

CCC:=CROSS(VARZZ1,VARZZ2) AND H>REF(H,1) AND C>REF(C,1) ;

CF1:=BARSLAST(CC);{买点日期}

CF2:=CF1<3;{5日内的线}

CF3:=CF2 AND C>REF(C,1);

CD:=CROSS(VARZZ2,VARZZ1);

DRAWTEXT(CC,L*0.98,'买'),COLORFF00FF;{输出粉红色的买字};

 


免责声明:本文系转载,版权归原作者所有;旨在传递信息,不代表本站的观点和立场。

热门TAGS

更多>>
公式频道
股票软件
配资资讯
财经频道
股票开户
理财频道
股票入门
技术分析
技术进阶
高手养成
配资平台